Bloom configuration with SSO fails
Incident Report for Neo4j Aura
Postmortem

What happened

As part of the Neo4j continuous release process we rolled out Bloom version 2.5.0 (upgrading from Bloom version 2.4.1) on Wednesday 19th October 2022 at approximately 10:00 UTC.

Upon rolling out the new version of Bloom, Aura Enterprise customers using SSO to login to Bloom  faced an error and couldn’t gain access. 

All other users Free / Professional and Enterprise not relying on SSO were unaffected.

How the service was affected

Users (Aura Enterprise only) attempting to sign-in to Bloom via SSO were faced with the login error : “Neo4j connectivity has been lost. Please check if your database instance is up and running”

Most customers could still revert to native authentication and resume work if they chose to do so.

Despite all our attempts to safeguard any existing functionality there was an issue in the implementation of the SSO login. Our normal software testing did not reveal any SSO related issue prior to release.

After some rapid investigations it was deemed not to be a configuration issue and we decided to roll-back the new version and revert to Bloom version 2.4.1 meanwhile we could correct the issue.

What we are doing now

We are improving our pre-release testing processes to better detect this type of scenario prior to future releases. We have also taken steps to make a roll-back of versions easier and faster for our teams to perform as an extra safety.

Posted Oct 24, 2022 - 16:35 UTC

Resolved
SSO login in Bloom has been returned to operational status. We are closing this incident. If you are still seeing problems please reach out to support at aura-support@neo4j.com.
Posted Oct 19, 2022 - 18:50 UTC
Monitoring
We have fixed the problem and are now monitoring the situation and will update the status page shortly after we have confirmed the fix is working for all affected customers.
Posted Oct 19, 2022 - 17:55 UTC
Update
We are still working at addressing this issue and we are currently implementing a fix.
We plan to communicate an ETA in our next update.
Posted Oct 19, 2022 - 17:18 UTC
Identified
We have now identified the cause of the issue and we are actively working at a fix.
As a workaround for affected users (Aura Enterprise with SSO enabled only) you can access Bloom by using the native authentication.
Posted Oct 19, 2022 - 16:27 UTC
Investigating
Aura Enterprise customers with SSO configuration for Bloom are unable to connect.
We are investigating and will update you shortly.

All other Bloom users for Professional and Free tiers are unaffected
Posted Oct 19, 2022 - 15:55 UTC
This incident affected: Neo4j User Tools (Bloom (bloom.neo4j.io)).