Neo4j Support Portal is experiencing a service disruption

Incident Report for Neo4j Aura

Postmortem

What happened

On Monday March 18th 2025 at 05:35 UTC, a Neo4j Customer Portal outage was reported which made it impossible for customers to create or manage their support tickets through the portal (https://support.neo4j.com). This outage was caused by a CA-signed certificate expiring which customers used to securely gain access to Neo4j’s support portal via Salesforce. Access was restored for customers around 13:00 UTC on March 18th as a result of creating a new CA-signed certificate and applying it to production. While the portal was inaccessible to customers, Neo4j Support Engineers could still work cases internally and accept email submitted cases. We apologize for the inconvenience this caused and appreciate your understanding and patience.

Root Cause

The Customer Support certificate for support.neo4j.com was created as part of Neo4j’s Service Cloud migration in March 2024. As a best practice, Salesforce limits CA-signed certificates to a one-year validity period primarily for security and compliance reasons. The teams that manage this system at Neo4j misunderstood how this certificate worked and did not renew it on time as a result. 

Customer Impact

  • Neo4j Customer Portal was unavailable for users for 7.5 hours.
  • Customers were able to receive case updates via email, and submit new cases via email.

Resolution

To prevent future missed certificate renewals, our team has dedicated resources who will be responsible for proactively monitoring, renewing, and managing all expiring certificates. We now have alerts configured that message the whole team 60 days in advance to make sure we don’t miss deadlines in the future.

The certificate process has also been documented thoroughly in our internal systems so that there is visibility on renewal steps across the teams responsible for managing the system.

Posted Apr 15, 2025 - 01:13 UTC

Resolved

We have fixed the issue and the support portal is now fully functional.
Posted Mar 18, 2025 - 13:16 UTC

Update

We are still investigating the issue affecting the Neo4j Support Portal (https://support.neo4j.com/). Users may continue to experience access difficulties, but updating existing cases via email remains unaffected.

Please report any issues via support@neo4j.com.We appreciate your patience and will share updates as soon as we have more information
Posted Mar 18, 2025 - 13:08 UTC

Update

We are still investigating the issue affecting the Neo4j Support Portal (https://support.neo4j.com/). Users may continue to experience access difficulties, but updating existing cases via email remains unaffected.

Please report any issues via support@neo4j.com.We appreciate your patience and will share updates as soon as we have more information
Posted Mar 18, 2025 - 10:35 UTC

Update

We are still actively working to resolve the ongoing disruption impacting the Neo4j Support Portal (https://support.neo4j.com/).

Users may experience challenges when signing in, creating new support cases, managing existing cases, or accessing knowledge base articles. For now, please continue submitting any issues via email at support@neo4j.com, as mentioned in our previous update.

We appreciate your patience and will provide further updates as soon as possible.
Posted Mar 18, 2025 - 08:44 UTC

Update

We are still actively investigating the ongoing service disruption affecting the Neo4j Customer Support Portal (https://support.neo4j.com/).

Users may continue to experience difficulties signing in, opening new support cases, managing existing cases, and accessing knowledge base articles. In the meantime, please continue reporting any issues via email at support@neo4j.com. We appreciate your patience and will provide further updates as we learn more.
Posted Mar 18, 2025 - 07:30 UTC

Investigating

Neo4j Support Portal (https://support.neo4j.com/) is experiencing a service disruption

- We are assessing the impact at this stage
- Users may encounter difficulty in signing-in and accessing the portal
- Users may have difficulty in opening New support cases, managing existing cases and in accessing the knowledgebase articles

Note: Users can update existing cases via email without any challenges

In the meantime, please report any issues via email at support@neo4j.com.
Posted Mar 18, 2025 - 06:24 UTC
This incident affected: Customer Support Portal (support.neo4j.com).