New users facing issues accessing Neo4j Aura Console
Incident Report for Neo4j Aura
Postmortem

What happened

We deployed a fix to a bug to address a race condition in registering new users on Aura. The fix aimed to address specifically a situation whereby multiple records could be created accidentally because they were bundled in the same transaction for the backend database and we therefore decided to split these operations. Unfortunately, in fixing it this way we blocked new user registration as the sequence of operations in registering users would be incorrect.

How the service was affected

New users registering for Aura faced an error: "Error project not found" or "An error occurred" with some Event ID. This prevented access for new users to progress further. However, all existing users were unaffected and no production workload was affected.

We were notified by the customers of issues and needed to deploy the fix as no workaround was identified at the time. As registering to the support portal is bundled with registering to Aura this error hindered new customers from notifying us of the problem. As a fallback channel, emails sent to support@neo4j.com from un-registered Support Portal users create a ticket but these tickets do not carry severity or SLA for response.

What we are doing now

We have identified several actions that can prevent similar problems from occurring in the future, including but not limited to those concerning new user registrations in Aura.

  • Add some automated tests for operations on our backend database managing the registration details so that we validate against the good usage with regards to the specific needs of transactions. Tests would verify that READ and WRITES aren’t bundled in a conflicting way for each of our API operations.
  • Implement a User Registration release check: to avoid issues creeping into production
  • To improve our troubleshooting capabilities we will be adding further information into the logs to establish a connection between Event Error ID and its corresponding log in the backend database.
Posted Jan 31, 2025 - 13:39 UTC

Resolved
A fix was released and rolled-out. All new users registering to Aura can access the Neo4j Aura Console
Posted Jan 20, 2025 - 08:25 UTC
Identified
New users registering for Aura faced an error: "Error project not found" or "An error occurred" with some Event ID
This prevented access for new users to progress further.
All existing users were unaffected and no production workload was affected.
Posted Jan 17, 2025 - 11:45 UTC
This incident affected: Aura Console (console.neo4j.io).