Console.neo4j.io is unavailable
Incident Report for Neo4j Aura
Postmortem

What happened

Due to some issues with connecting to a third party service Neo4j Aura Console (console.neo4j.io) was down between 2023-04-10 21:18:55 UTC and 2023-04-10 23:37:25 UTC.
Upstream requests from the Aura Console to a third party service began to take a long time to respond, resulting in server processes being killed and restarted repeatedly.

How the service was affected

Customers were unable to gain access to the Aura Console to manage and monitor database instances.As reported at the time, this issue did not affect running databases and customers could still connect to them using Cypher Shell or their chosen driver.  Also connection via Bloom & Browser was possible using the appropriate URLs.

What we are doing now

Third party services dependencies built into the Aura Console have been checked and are now running well. We are closely monitoring the situation to detect any degradation.

A number of remediating actions have been identified that could help to avoid this happening again in future and improve incident handling should it occur again. 

Preventative

All upstream requests without implemented timeouts are being configured to add a threshold, to limit the chances of non-responsive services from bringing the Console down.

Observability

Improved logging observability so any future issues are easier to  detect and faster to resolve.

Posted Apr 14, 2023 - 09:57 UTC

Resolved
This incident has been resolved. Console.neo4j.io is accessible.
Posted Apr 11, 2023 - 00:55 UTC
Monitoring
Logging into console.neo4j.io has been restored. We are continuing to monitor the situation and will update you the status as it changes.
Posted Apr 10, 2023 - 23:48 UTC
Update
We are still investigating the issue. In the interim, you can go to https://bloom.neo4j.io/index.html?connectURL=neo4j%2Bs%3A//[dbid].databases.neo4j.io or https://[dbid].databases.neo4j.io/browser/ (use the appropriate DBID) to access your database in either Bloom or Browser, respectively.

You can find out more about going directly to your database in this knowledgebase article: https://aura.support.neo4j.com/hc/en-us/articles/1500010083322-Working-in-teams-on-your-AuraDB-Instance.
Posted Apr 10, 2023 - 22:54 UTC
Update
We are continuing to investigate the issue. You can still get to https://browser.neo4j.io/ or https://bloom.neo4j.io/ directly. We will continue to update you as we have more information.
Posted Apr 10, 2023 - 22:10 UTC
Investigating
Customers may experience inability to load console.neo4j.io. You will see an "Unable to load". This does not affect your running databases and you can still connect to them using Cypher Shell or your driver. This only affects login to the console.
Posted Apr 10, 2023 - 21:48 UTC
This incident affected: Aura Console (console.neo4j.io).