Issues creating new instances on AuraDB Professional AWS region us-east-1
Incident Report for Neo4j Aura
Postmortem

What happened

Customers could not create any further database instances in AWS Aura Professional us-east-1 environment region. The configuration of resources applied to this environment was not suited to the Aura Professional tier as being too limiting of resources in the number of instances it could accommodate. 

How the service was affected

The impact to customers was that they would not be able to create new instances (nor be able to clone to a new instance) for that period of time (2023-11-26 at 15:41 UTC - 2023-11-27 at 08:44 UTC). 

Another impact was that some database instances were not completing a successful roll (version update or resize) but at no point were any database instances losing availability (no impact to customers’ workload). 

What we are doing now

We have reviewed the configuration of resources of all similar regions and where necessary made some corrections.

We are putting in place a new alarm, and setup a method for detection of such issues and will be monitoring with a view to address such events before they risk impacting customers.

Posted Dec 08, 2023 - 17:31 UTC

Resolved
All operations are confirmed to be fully restored.
Posted Nov 27, 2023 - 09:33 UTC
Monitoring
We have now identified the root cause and issued a fix.
All operations should have resumed and all functionality is recovered.
We will monitor a few minutes and update shortly.
Posted Nov 27, 2023 - 09:09 UTC
Investigating
We are experiencing issues in a particular environment - AWS us-east-1.
Creation of new instances is failing. We are investigating and will update shortly.
This only affects AuraDB Professional tier in this region.
Posted Nov 27, 2023 - 08:38 UTC
This incident affected: AuraDB Professional (*.databases.neo4j.io).