Operations requiring system database fail when not connected directly to the system database
Incident Report for Neo4j Aura
Resolved
We have successfully rolled out a fix and this issue is now fixed.
Posted Jun 04, 2024 - 09:56 UTC
Update
We have identified a problem with the routing of some internal messages, which impacts some operations for Aura Enterprise and Aura Professional customers.

The scope of operations would be anything that involves using the system database while connected to the neo4j database. For example, such commands and queries might involve database user management.

The workaround is to directly connect to the system database and run these commands. If using Workspace or Browser, you can switch to the system database with the command ":USE system".
If using the Neo4j drivers, specify "system" as the database name to connect to in the driver's code.

The root cause has been identified, and we are working on rolling out a fix.
Posted Jun 04, 2024 - 07:00 UTC
Update
We have identified a problem with the routing of some internal messages, which impacts some operations for Aura Enterprise and Aura Professional customers.

The scope of operations would be anything that involves using the system database while connected to the neo4j database. For example, such commands and queries might involve database user management.

The workaround is to directly connect to the system database and run these commands. If using Workspace or Browser, you can switch to the system database with the command ":USE system".
If using the Neo4j drivers, specify "system" as the database name to connect to in the driver's code.

The root cause has been identified, and we are working on rolling out a fix.
Posted Jun 04, 2024 - 01:08 UTC
Update
We have identified a problem with the routing of some internal messages, which impacts some operations for Aura Enterprise and Aura Professional customers.

The scope of operations would be anything that involves using the system database while connected to the neo4j database. For example, such commands and queries might involve database user management.

The workaround is to directly connect to the system database and run these commands. If using Workspace or Browser, you can switch to the system database with the command ":USE system".
If using the Neo4j drivers, specify "system" as the database name to connect to in the driver's code.

The root cause has been identified, and we are working on rolling out a fix.
Posted Jun 03, 2024 - 13:19 UTC
Update
We have identified a problem with the routing of some internal messages, which impacts some operations for Aura Enterprise and Aura Professional customers.

The scope of operations would be anything that involves using the system database while connected to the neo4j database. For example, such commands and queries might involve database user management.

The workaround is to directly connect to the system database and run these commands. If using Workspace or Browser, you can switch to the system database with the command ":USE system".
If using the Neo4j drivers, specify "system" as the database name to connect to in the driver's code.

The root cause has been identified, and we are working on rolling out a fix.
Posted Jun 03, 2024 - 07:02 UTC
Update
We have identified a problem with the routing of some internal messages, which impacts some operations for Aura Enterprise and Aura Professional customers.

The scope of operations would be anything that involves using the system database while connected to the neo4j database. For example, such commands and queries might involve database user management.

The workaround is to directly connect to the system database and run these commands. If using Workspace or Browser, you can switch to the system database with the command ":USE system".
If using the Neo4j drivers, specify "system" as the database name to connect to in the driver's code.

The root cause has been identified, and we are working on rolling out a fix.
Posted Jun 03, 2024 - 01:00 UTC
Update
We have identified a problem with the routing of some internal messages, which impacts some operations for Aura Enterprise and Aura Professional customers.

The scope of operations would be anything that involves using the system database while connected to the neo4j database. For example, such commands and queries might involve database user management.

The workaround is to directly connect to the system database and run these commands. If using Workspace or Browser, you can switch to the system database with the command ":USE system".
If using the Neo4j drivers, specify "system" as the database name to connect to in the driver's code.

The root cause has been identified, and we are working on rolling out a fix.
Posted Jun 02, 2024 - 19:00 UTC
Update
We have identified a problem with the routing of some internal messages, which impacts some operations for Aura Enterprise and Aura Professional customers.

The scope of operations would be anything that involves using the system database while connected to the neo4j database. For example, such commands and queries might involve database user management.

The workaround is to directly connect to the system database and run these commands. If using Workspace or Browser, you can switch to the system database with the command ":USE system".
If using the Neo4j drivers, specify "system" as the database name to connect to in the driver's code.

The root cause has been identified, and we are working on rolling out a fix.
Posted Jun 02, 2024 - 13:28 UTC
Update
We have identified a problem with the routing of some internal messages, which impacts some operations for Aura Enterprise and Aura Professional customers.

The scope of operations would be anything that involves using the system database while connected to the neo4j database. For example, such commands and queries might involve database user management.

The workaround is to directly connect to the system database and run these commands. If using Workspace or Browser, you can switch to the system database with the command ":USE system".
If using the Neo4j drivers, specify "system" as the database name to connect to in the driver's code.

We have identified the root cause and are working on rolling out a fix.
Posted Jun 02, 2024 - 07:02 UTC
Update
We have identified a problem with the routing of some internal messages, which impacts some operations for Aura Enterprise and Aura Professional customers.

The scope of operations would be anything that involves using the system database while connected to the neo4j database. For example, such commands and queries might involve database user management.

The workaround is to directly connect to the system database and run these commands. If using Workspace or Browser, you can switch to the system database with the command ":USE system".
If using the Neo4j drivers, specify "system" as the database name to connect to in the driver's code.

We have identified the root cause and are working on rolling out a fix.
Posted Jun 02, 2024 - 01:00 UTC
Identified
We have identified a problem with the routing of some internal messages, which impacts some operations for Aura Enterprise and Aura Professional customers.

The scope of operations would be anything that involves using the system database while connected to the neo4j database. For example, such commands and queries might involve user management.

The workaround is to directly connect to the system database and run these commands. If using Workspace or Browser, you can switch to the system database with the command ":USE system".
If using the Neo4j drivers, specify "system" as the database name to connect to in the driver's code.

We have identified the root cause and are working on rolling out a fix.
Posted Jun 01, 2024 - 17:36 UTC
Update
We have identified a problem with the routing of some internal messages which impacts some operations for Aura Enterprise and Aura Professional customers.

The scope of operations would be anything that involves using the system database while connected to the neo4j database. Such commands and queries might involve user management as an example.

The workaround is to connect to the system database directly and run these commands. If using Workspace or Browser, you can switch to the system database with the command ":USE system". If using the Neo4j drivers, specify "system" as the database name to connect to in the driver's code.

We are currently investigating the root cause and will update this incident with progress.
Posted Jun 01, 2024 - 10:17 UTC
Update
We have identified a problem with the routing of some internal messages which impacts some operations for Aura Enterprise and Aura Professional customers.

The scope of operations would be anything that involves updating the system database while connected to the neo4j database. Such commands and queries might involve user management as an example.

The workaround is to connect to the system database directly and run these commands. If using Workspace or Browser, you can switch to the system database with the command ":USE system". If using the Neo4j drivers, specify system as the database name to connect to.

We are currently investigating the root cause and will update this incident with progress.
Posted Jun 01, 2024 - 04:04 UTC
Investigating
We have identified a problem with the routing of some internal messages which impacts some operations for Aura Enterprise and Aura Professional customers.

The scope of operations would be anything that involves updating the system database while connected to the neo4j database. Such commands and queries might involve user management as an example.

The workaround is to connect to the system database directly and run these commands. If using Workspace or Browser, you can switch to the system database with the command ":USE system". If using the Neo4j drivers, specify system as the database name to connect to.

We are currently investigating the root cause and will update this incident with progress.
Posted May 31, 2024 - 22:03 UTC
This incident affected: AuraDB Enterprise (*.databases.neo4j.io) (AuraDB Enterprise on AWS (*.databases.neo4j.io), AuraDB Enterprise on Azure (*.databases.neo4j.io), AuraDB Enterprise on GCP (*.databases.neo4j.io)), AuraDB Professional (*.databases.neo4j.io) (AuraDB Professional on AWS (*.databases.neo4j.io), AuraDB Professional on Azure (*.databases.neo4j.io), AuraDB Professional on GCP (*.databases.neo4j.io)), AuraDS (*.databases.neo4j.io) (AuraDS on AWS (*.databases.neo4j.io), AuraDS on Azure (*.databases.neo4j.io), AuraDS on GCP (*.databases.neo4j.io)), and AuraDS Enterprise (*.databases.neo4j.io) (AuraDS Enterprise on AWS (*.databases.neo4j.io), AuraDS Enterprise on Azure (*.databases.neo4j.io), AuraDS Enterprise on GCP (*.databases.neo4j.io)).