AuraDB Free tier: query performance degraded
Incident Report for Neo4j Aura
Postmortem

What happened

A new feature to optimize query execution relating to the eager operation was released. Under some conditions certain Cypher statements with MERGE and CREATE operations would become inefficient on low resourced instances consuming more memory. 

How the service was affected

Some queries would fail to complete or take an abnormal level of resources. This was mostly affecting AuraDB Free users or smaller instances of the Professional tier (1GB RAM) due to the limited resources available in both compute and memory.

What we are doing now

  • We are now specifically testing on small instances 
  • Benchmarking the features on low resources machines before rolling out
Posted Jul 17, 2024 - 15:33 UTC

Resolved
This issue has now been resolved and the performance is restored.
Posted Apr 25, 2024 - 13:05 UTC
Monitoring
A fix has been rolled out and we are monitoring the effects and validating this address the issues.
Posted Apr 25, 2024 - 12:35 UTC
Update
We are rolling out the fix and will continue to update you as things progress.
Posted Apr 25, 2024 - 09:54 UTC
Update
We are continuing to work on getting a fix rolled out.
We will continue to update you as things progress.
Posted Apr 25, 2024 - 07:30 UTC
Update
We are continuing to work on getting a fix rolled out.
We will continue to update you as things progress.
Posted Apr 25, 2024 - 04:30 UTC
Update
We are continuing to get a fix rolled out.
We do not currently have an ETA, but we will continue to update you on a regular basis.
Posted Apr 25, 2024 - 01:47 UTC
Update
We are continuing to work on getting a fix rolled out.
We will continue to update you as things progress.
Posted Apr 24, 2024 - 22:32 UTC
Update
We are continuing to work on getting a fix rolled out.
We will continue to update you as things progress.
Posted Apr 24, 2024 - 16:04 UTC
Update
We are continuing to work on getting a fix rolled out.
We will continue to update you as things progress.
Posted Apr 24, 2024 - 12:28 UTC
Update
We are continuing to get a fix rolled out.
We do not currently have an ETA, but we will continue to update you on a regular basis.
Posted Apr 24, 2024 - 10:01 UTC
Update
We are continuing to work on getting a fix rolled out.
We will continue to update you as things progress.
Posted Apr 24, 2024 - 07:01 UTC
Update
We are continuing to get a fix rolled out.
We do not currently have an ETA, but we will continue to update you on a regular basis.
Posted Apr 24, 2024 - 04:00 UTC
Update
We are continuing to work on getting a fix rolled out. We will continue to update you as things progress.
Posted Apr 23, 2024 - 23:25 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 23, 2024 - 21:20 UTC
Update
We are continuing to get a fix rolled out. We do not currently have an ETA but we will continue to update you on a regular cadence.
Posted Apr 23, 2024 - 18:16 UTC
Update
We are preparing and fix and will roll this out at our next opportunity.
Posted Apr 23, 2024 - 16:31 UTC
Update
We have identified the root cause and are working on rolling out a fix.
Posted Apr 23, 2024 - 14:26 UTC
Identified
We have identified the issue more precisely and continue to work on a fix.
Posted Apr 23, 2024 - 12:27 UTC
Investigating
We are currently investigating an issue where some queries are not performing well.
Posted Apr 23, 2024 - 10:33 UTC
This incident affected: AuraDB Free (*.databases.neo4j.io).