Customer portal case creation issues
Incident Report for Neo4j Aura
Postmortem

What happened

We deployed an improvement to the Customer portal aimed at fixing the way our response emails are reported. This update was impacted by another change on the CRM system for an unrelated purpose.

How the service was affected

A subset of customers were unable to log in to the portal to consult, create or update their support cases. Email updates for existing cases were unaffected.

The alternate way to report issues (as specified in our Customer Support Reference guide) via email to support@neo4j.com remained available throughout and our agents were actively monitoring for new cases to quickly assess the severity.

What we are doing now

We have updated our (internal) change management procedures to avoid CRM rollouts that interfere with each other.

We will be reviewing our disaster recovery procedures to ensure measures are up to date and our staff is trained to continue operating in case of an outage to our Customer portal.

Posted May 28, 2024 - 20:30 UTC

Resolved
Customer can create support tickets and all features have been fully recovered.
Posted May 09, 2024 - 13:44 UTC
Monitoring
We have deployed a fix and submitting support cases is working.
We will monitor this and verify all is fixed.
Posted May 09, 2024 - 13:40 UTC
Investigating
We are currently investigating an issue with customer support case creation.
If you face errors using the portal, please raise the support request by email to support@neo4j.com
Posted May 09, 2024 - 13:12 UTC
This incident affected: Customer Support Portal (support.neo4j.com).