Customer portal issues
Incident Report for Neo4j Aura
Postmortem

What happened

During the migration process from our legacy Support Portal to the new Customer Portal connected to our existing Customer Relationship Management (CRM) system, some customer records were merged in conflict with pre-existing records. As a result of this, the system rejected the login attempts from users with multiple records as a fail-safe. This resulted in a number of users receiving SSO sign-in errors when trying to access the Customer Portal.

Once these initial conflicts had been resolved, some customer users were left detached from their organization which led the users not being able to see their organization data, such as users, projects and existing cases, and likewise could not open a new case without access to these organization-level records. At no time were any users able to see organization data to which they were not affiliated.

How the service was affected

A majority of Neo4j customers could not sign-in to the new customer portal which prevented access to existing support tickets or the raising of new tickets.

The Neo4j Disaster Recovery (DR) procedures, leveraging email submissions to support@neo4j.com, was effective and allowed customers access to technical support resources. Email correspondence between Neo4j and customers on existing tickets was unaffected once a new thread was initiated by Neo4j Support. 

What we are doing now

Whilst, through our DR procedure, we managed to keep the customer support service functioning, there were learnings leading to potential improvements to the DR procedures. Neo4j is in the process of updating the procedures to ensure the effectiveness when needed and to further improve on our ability to interact with customers in these rare situations.

We strongly encourage all customers, with prior access to the legacy Support Portal, to verify login access to https://support.neo4j.com/s/, review a few KB articles describing the site, and confirm the ability to submit a new ticket. If login or case submission failures persist, email support@neo4j.com with details. All other customers should resume filing new tickets via the Customer Portal at https://support.neo4j.com/s/

Posted Apr 02, 2024 - 13:20 UTC

Resolved
Data migration is now completed successfully and the customer portal is functional.
All registered users can sign-in to https://support.neo4j.com.
Posted Mar 21, 2024 - 14:59 UTC
Update
We are still progressing on the migration to our new customer portal. Most users have been migrated and activated, but some remain to be processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com
Posted Mar 21, 2024 - 14:37 UTC
Update
We are still progressing on the migration to our new customer portal. Most users have been migrated and activated, but some remain to be processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com
Posted Mar 21, 2024 - 09:38 UTC
Update
We are still progressing on the migration to our new customer portal. Most users have been migrated and activated, but some remain to be processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com
Posted Mar 21, 2024 - 06:01 UTC
Update
We are still progressing on the migration to our new customer portal. Most users have been migrated and activated, but some remain to be processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com
Posted Mar 21, 2024 - 03:00 UTC
Update
We are still progressing on the migration to our new customer portal. Most users have been migrated and activated, but some remain to be processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com.
Posted Mar 21, 2024 - 00:14 UTC
Update
We are still progressing on the migration to our new customer portal. Most users have been migrated and activated, but some remain to be processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com.
Posted Mar 20, 2024 - 21:16 UTC
Update
We are still progressing on the migration to our new customer portal. Most users have been migrated and activated, but some remain to be processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com.
Posted Mar 20, 2024 - 18:13 UTC
Update
We are still progressing on the migration to our new customer portal. Most users have been migrated and activated, but some remain to be processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com
Posted Mar 20, 2024 - 15:22 UTC
Update
We are still progressing on the migration to our new customer portal. Most users have been migrated and activated, but some remain to be processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com
Posted Mar 20, 2024 - 12:21 UTC
Update
We are still progressing on the migration to our new customer portal. Most users have been migrated and activated, but some remain to be processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com
Posted Mar 20, 2024 - 09:33 UTC
Update
We are still progressing on the migration to our new customer portal. Most users have been migrated and activated, but some remain to be processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com
Posted Mar 20, 2024 - 06:35 UTC
Update
We are still progressing on the migration to our new customer portal. Most users have been migrated and activated, but some remain to be processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com.
Posted Mar 20, 2024 - 02:44 UTC
Update
We are still progressing on the migration to our new customer portal. Most users have been migrated and activated, but some remain to be processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com.
Posted Mar 19, 2024 - 23:28 UTC
Update
We are still progressing on the migration to our new customer portal. Most users have been migrated and activated, but some remain to be processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com.
Posted Mar 19, 2024 - 20:26 UTC
Update
We are still progressing on the migration to our new customer portal. Many users have been migrated and activated, but not all have been processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com
Posted Mar 19, 2024 - 15:47 UTC
Update
We are still progressing on the migration to our new customer portal. Many users have been migrated and activated, but not all have been processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com
Posted Mar 19, 2024 - 12:33 UTC
Update
We are still progressing on the migration to our new customer portal. Many users have been migrated and activated, but not all have been processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com
Posted Mar 19, 2024 - 09:27 UTC
Update
We are still progressing on the migration to our new customer portal. Many users have been migrated and activated, but not all have been processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com
Posted Mar 19, 2024 - 06:05 UTC
Update
We are still progressing on the migration to our new customer portal. Many users have been migrated and activated, but not all have been processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com.
Posted Mar 19, 2024 - 03:08 UTC
Update
We are still progressing on the migration to our new customer portal. Many users have been migrated and activated, but not all have been processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com.
Posted Mar 18, 2024 - 23:04 UTC
Update
We are still progressing on the migration to our new customer portal. Many users have been migrated and activated, but not all have been processed. You will receive an email once your access has been migrated and activated.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com.
Posted Mar 18, 2024 - 20:12 UTC
Update
Aura Enterprise customers can now accept invites to Aura Console environments

We are still progressing on the migration to our new customer portal.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com.
Posted Mar 18, 2024 - 16:59 UTC
Update
We are deploying a fix for the Aura Console so that Enterprise tier users can accept invites.

We continue to progress on the data migration to the new customer portal.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com.
Posted Mar 18, 2024 - 14:19 UTC
Update
We continue to work on the completion of the data migration to restore full access to the customer portal.
Currently some customers may face issues logging in. When you receive the welcome email you will be able to sign-in.

Aura customers cannot accept invites to their environments and the fix for this is also currently in progress.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com.
Posted Mar 18, 2024 - 12:24 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 18, 2024 - 10:33 UTC
Identified
We are currently experiencing some delay in the full data migration to our new customer portal.
Currently some customers may face issues logging in. When you receive the welcome email you will be able to sign-in.

Aura customers cannot accept invites to their environments and the fix for this is also currently in progress.

If you cannot yet access the support portal but need to raise a support issue, please use support@neo4j.com.
Posted Mar 18, 2024 - 10:32 UTC
This incident affected: Aura Console (console.neo4j.io) and Customer Support Portal (support.neo4j.com).