Several operations degraded for AWS instances in region us-east-1

Incident Report for Neo4j Aura

Resolved

Instance operations in AWS us-east-1 region are back to normal following the resolution of the AWS incident. We will continue to monitor but all data indicates that the issue is fully resolved at this time.
Posted Oct 20, 2025 - 21:28 UTC

Update

We are continuing to monitor the AWS incident, and can report some slow improvement of impacted Aura instances in the AWS us-east1 region, though the service remains degraded in this region at this time.

We are continuing to monitor progress in the AWS incident: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 19:14 UTC

Identified

Many core operations for instances in AWS region us-east-1 are degraded as a result of AWS incident in that region: https://health.aws.amazon.com/health/status

Core operations include create, pause, resume, clone, backup, among others.

We continue to monitor the AWS incident and will provide updates accordingly.
Posted Oct 20, 2025 - 16:43 UTC
This incident affected: AuraDB Virtual Dedicated Cloud (*.databases.neo4j.io) (AuraDB Virtual Dedicated Cloud on AWS (*.databases.neo4j.io)), AuraDB Professional (*.databases.neo4j.io) (AuraDB Professional on AWS (*.databases.neo4j.io)), AuraDS (*.databases.neo4j.io) (AuraDS on AWS (*.databases.neo4j.io)), AuraDS Enterprise (*.databases.neo4j.io) (AuraDS Enterprise on AWS (*.databases.neo4j.io)), AuraDB Business Critical (*.databases.neo4j.io) (AuraDB Business Critical (*.databases.neo4j.io) on AWS), and Aura Graph Analytics (Aura Graph Analytics on AWS).