AuraDB issue: Errors when running CREATE VECTOR INDEX

Incident Report for Neo4j Aura

Resolved

The fix has been fully deployed to all impacted instances. This incident is now resolved.
Posted Jun 30, 2026 - 17:45 UTC

Monitoring

A fix is rolling out and progressing well. We will update with progress.
Posted Jun 30, 2026 - 16:05 UTC

Update

We are starting now to deploy a fix to address this issue and will provide an update soon on progress.
Posted Jun 30, 2026 - 15:41 UTC

Identified

Running CREATE VECTOR INDEX fails with error 51N31
error: system configuration or operation exception - not supported. Creating a vector index with provided settings is not supported in V2026_02. Required version for operation is V2026_06. Please upgrade DBMS..

This only affects new index, existing VECTOR INDEX are unaffected.
Any vector index created prior to 2026-06-30 at 09:00 continue to operate normally.
Posted Jun 30, 2026 - 14:45 UTC
This incident affected: AuraDB Professional (*.databases.neo4j.io) (AuraDB Professional on AWS (*.databases.neo4j.io), AuraDB Professional on Azure (*.databases.neo4j.io), AuraDB Professional on GCP (*.databases.neo4j.io)), AuraDS Enterprise (*.databases.neo4j.io) (AuraDS Enterprise on AWS (*.databases.neo4j.io), AuraDS Enterprise on Azure (*.databases.neo4j.io), AuraDS Enterprise on GCP (*.databases.neo4j.io)), and AuraDB Business Critical (*.databases.neo4j.io) (AuraDB Business Critical (*.databases.neo4j.io) on AWS, AuraDB Business Critical (*.databases.neo4j.io) on Azure, AuraDB Business Critical (*.databases.neo4j.io) on GCP).