Aura Console is currently unreachable

Incident Report for Neo4j Aura

Postmortem

What happened

On June 12, 2025, at 17:49 UTC, a service disruption occurred affecting the Aura Console, Aura API, CMI, and Aura Graph Analytics, making them fully unavailable for approximately 1.5 hours. The issue was caused by a change in the Google Cloud Platform (GCP) that led to errors in communication with the Aura Console API. The problem was identified quickly, and services began to recover around 19:04 UTC. By 01:27 UTC on June 13, GCP confirmed that all services were fully restored. We apologize for any inconvenience this may have caused and appreciate your understanding.

How customers were affected

The outage was caused by a recent update in Google Cloud Platform (GCP) affecting the Data store service. This update inadvertently affected the way our systems interact with GCP services, leading to a temporary disruption. Our team actively worked with GCP to monitor the issue and ensure that our systems became fully operational as quickly as possible. Details here: https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

The issue was promptly resolved by GCP reversing the change that caused the disruption, ensuring that our services were restored to normal operation.

What we are doing now

Neo4j remains committed to providing reliable service and is implementing additional safeguards to prevent similar incidents in the future.

New mitigations being deployed:

  • Enhancing our monitoring systems to detect similar issues faster
  • Implementing additional automated checks to prevent service disruptions
Posted Jul 23, 2025 - 13:46 UTC

Resolved

This incident has been resolved
Aura Console is operational and is available to use without any issues
Posted Jun 13, 2025 - 05:18 UTC

Monitoring

Aura Console should now be fully operational and available now that the underlying cloud provider's services have all recovered.
Posted Jun 13, 2025 - 00:23 UTC

Update

We are updating this to partial outage as Console is reachable more consistently in recent tests. The underlying cause of the outage for our cloud providers is still under investigation.

According to that, services are restoring and we expect full operations once that is fully restored.
Posted Jun 12, 2025 - 19:33 UTC

Identified

The identified issue is reported on our cloud provider's status page: https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

We are continuing to work to restore Console availability.
Posted Jun 12, 2025 - 19:13 UTC

Update

Our cloud provider is currently experiencing an outage that is impacting Aura Console reachability. At this point it is reachable but may be intermittent until the the outage is fully resolved.
Posted Jun 12, 2025 - 18:57 UTC

Investigating

We've detected that Aura Console is currently unreachable. We are actively investigating this incident. Individual instances should not be effected.
Posted Jun 12, 2025 - 18:42 UTC
This incident affected: Aura Console (console.neo4j.io).