Customer support portal issues

Incident Report for Neo4j Aura

Resolved

A fix has been deployed and all functionality should now be recovered.
Posted Sep 16, 2026 - 14:31 UTC

Update

Our support portal provider continues to roll out a fix.
Posted Sep 16, 2026 - 12:29 UTC

Monitoring

A fix is being rolled out and the portal should become less impacted by errors over time. See details https://status.salesforce.com/incidents/20004433
Posted Sep 16, 2026 - 11:30 UTC

Update

Our support portal provider continues to work on addressing the issue. See details here https://status.salesforce.com/incidents/20004433
Posted Sep 16, 2026 - 10:11 UTC

Update

Our support portal provider is still working on addressing the issue. See details here https://status.salesforce.com/incidents/20004433
Posted Sep 16, 2026 - 09:16 UTC

Identified

Our service provider for the support portal is experiencing some outage - See https://status.salesforce.com/products/Salesforce_Services

If you experience issues submitting a new support case, please send email to support@neo4j.com
Posted Sep 16, 2026 - 08:50 UTC
This incident affected: Customer Support Portal (support.neo4j.com).