Aura Console temporarily unavailable

Incident Report for Neo4j Aura

Postmortem

What happened

On March 28, 2025, some users experienced difficulties accessing the Aura Console due to a temporary issue with our system. The problem was identified quickly, and a solution was implemented to restore full functionality. We apologize for any inconvenience this may have caused and appreciate your patience as we worked to resolve the issue and improve the service.

Root Cause

We encountered an issue where under certain circumstances an older version of the @neo4j/graphql library was loaded which was not compatible with the browser environment. As a result, you might have experienced some disruptions or errors while using our service. 

Customer Impact

  • Some users were unable to access the Aura console for a short period.
  • Users needed to refresh their browser’s cache or wait for a fix to regain access to the Aura Console.

Resolution

We have updated our service, removing the feature from the console which loaded the library in the browser, which avoids this situation altogether.

What we are doing now

Neo4j remains committed to providing reliable service and is implementing additional safeguards to prevent similar incidents in the future.

New mitigations being deployed:

  • Enhancing our testing environments to better reflect real-world conditions, ensuring more reliable service updates.
  • Implementing stricter release protocols to ensure only fully verified updates are deployed.
  • Improving our monitoring systems to detect potential issues before they impact our customers.
  • Increasing the reliability of our automated testing to ensure consistent service quality.
  • Developing a more robust notification system to keep our teams informed of any service issues promptly.
  • Enhancing our documentation and training to ensure all team members are well-prepared to handle service updates and incidents.
Posted Apr 16, 2025 - 16:21 UTC

Resolved

We can confirm that the change has resolved the issue and that Aura Console is fully operational at this time.
Posted Mar 28, 2025 - 18:20 UTC

Monitoring

We reverted a change that was rolled out earlier today and we can confirm this has addressed the issue but will keep on monitoring for some time.
Posted Mar 28, 2025 - 17:58 UTC

Identified

We have identified the issue being related to web browser cached files.
Clearing all files linked to the domain neo4j.io in your browser should allow you to login.
Alternatively please use https://console.neo4j.io
We continue to investigate a way to fix and will update shortly.
Posted Mar 28, 2025 - 17:42 UTC

Update

As we are continuing to investigate and remediate this issue with Aura Console, please use https://console.neo4j.io, which is still working normally.
Posted Mar 28, 2025 - 16:57 UTC

Investigating

We are currently investigating unavailability of the Aura Console. If you are logged into the Classic view, you are likely unaffected.
Posted Mar 28, 2025 - 16:39 UTC
This incident affected: Aura Console (console.neo4j.io).