Pause / Resume / Destroy operations failing

Incident Report for Neo4j Aura

Postmortem

What happened

On November 18, 2025, some customers experienced issues with the delete, pause, and resume operations in the Console. These actions failed due to a temporary system issue introduced during a sequence of updates. While the updates were intended to improve functionality, they unintentionally reintroduced a previously resolved defect.

The issue was identified quickly, and our teams acted immediately to restore normal operation.

The root cause was a misconfiguration in the data processing module. An outdated schema caused the data parsing logic to misinterpret certain input parameters, leading to incorrect behavior and data display within the Console. We have since corrected the schema and added stricter validation to ensure compatibility moving forward.

How customers were affected

During the incident, some users experienced service disruptions when accessing the Console. Impacts included:

  • Intermittent connectivity issues
  • Inability to log in
  • Temporary unavailability of specific Console features

No customer data was lost.

To prevent a recurrence, we have improved our release process to ensure updates are deployed in the correct order, eliminating overlapping or out-of-sequence changes.

What we are doing now

Neo4j takes service reliability seriously and is strengthening safeguards to prevent similar incidents.

New mitigations being deployed include:

  • Enhanced monitoring to detect related issues earlier
  • Additional automated checks to block faulty configurations before deployment
  • Improvements to overall service resilience to better tolerate similar failures

We apologize for the disruption and appreciate our customers’ patience as we continue to harden our systems.

Posted Jan 14, 2026 - 14:05 UTC

Resolved

After monitoring the fix for some time, we can confirm that the issue is resolved and normal operations have resumed.
Posted Nov 18, 2025 - 16:39 UTC

Monitoring

We have released a fix to this issue and are monitoring to ensure all operations are back to normal.
Posted Nov 18, 2025 - 16:16 UTC

Identified

We have identified an issue resulting in Pause, Resume and Delete operations to fail in both Console and Aura API across all tiers of Aura. We are actively working to resolve the issue and will report progress.
Posted Nov 18, 2025 - 15:56 UTC
This incident affected: AuraDB Virtual Dedicated Cloud (*.databases.neo4j.io) (AuraDB Virtual Dedicated Cloud on AWS (*.databases.neo4j.io), AuraDB Virtual Dedicated Cloud on Azure (*.databases.neo4j.io), AuraDB Virtual Dedicated Cloud on GCP (*.databases.neo4j.io)), AuraDB Professional (*.databases.neo4j.io) (AuraDB Professional on AWS (*.databases.neo4j.io), AuraDB Professional on Azure (*.databases.neo4j.io), AuraDB Professional on GCP (*.databases.neo4j.io)), AuraDS (*.databases.neo4j.io) (AuraDS on AWS (*.databases.neo4j.io), AuraDS on Azure (*.databases.neo4j.io), AuraDS on GCP (*.databases.neo4j.io)), AuraDS Enterprise (*.databases.neo4j.io) (AuraDS Enterprise on AWS (*.databases.neo4j.io), AuraDS Enterprise on Azure (*.databases.neo4j.io), AuraDS Enterprise on GCP (*.databases.neo4j.io)), AuraDB Business Critical (*.databases.neo4j.io) (AuraDB Business Critical (*.databases.neo4j.io) on AWS, AuraDB Business Critical (*.databases.neo4j.io) on Azure, AuraDB Business Critical (*.databases.neo4j.io) on GCP), and Aura API (api.neo4j.io), AuraDB Free (*.databases.neo4j.io).