Data science feature on AuraDS , AuraDSE and Aura Professional tiers - Native projection affected.

Incident Report for Neo4j Aura

Postmortem

What happened

On January 15, 2026 at 22:12 UTC we began rolling out an update that included an incompatible version of a key component, affecting customers using the GDS plugin. This issue was reported on January 16 at 12:59 UTC, and a fix was deployed within hours, restoring functionality for the majority of affected users by 20:03 UTC. 

The issue occurred because Neo4’s packaging automation process selected the wrong version of the GDS component. GDS 2.25 should have been selected but instead GDS 2.24 was included in the bundle, which caused a compatibility issue. Although a corrected package was created and labeled separately, the release pipeline selected the incorrect package for deployment. 

This issue highlighted a gap in the release validation process, where incompatible component versions were not detected before rollout.

How customers were affected

Customers using the GDS plugin were unable to use any of the functionality the plugin provides during the incident window. 

The system configuration has been updated to ensure compatibility with the intended component versions, restoring full functionality.

What we are doing now

The following mitigations have been implemented: 

  • Enhanced testing procedures to automatically verify compatibility between Neo4j and all bundled components before release.
  • Improved release processes to ensure that only explicitly validated and correctly labeled packages can be selected for deployment.
Posted Apr 23, 2026 - 13:27 UTC

Resolved

All instances should have the fix applied and if not it should be in the next 60 minutes
Posted Jan 16, 2026 - 19:36 UTC

Monitoring

The fix is currently rolling out to production. We will update you upon completion
Posted Jan 16, 2026 - 17:07 UTC

Update

Our teams have a fix and initiated the work to get it ready to roll-out.
No current ETA available.
We will keep you updated soon.
Posted Jan 16, 2026 - 15:13 UTC

Identified

Impact is that currently it is not possible to load data into GDS via native projection.
Customers using Aura Graph Analytics are not impacted.
We have identified a packaging issue with the latest release of Aura.
Our engineering team is working on a fix.
Posted Jan 16, 2026 - 14:25 UTC
This incident affected: AuraDB Professional (*.databases.neo4j.io) (AuraDB Professional on AWS (*.databases.neo4j.io), AuraDB Professional on Azure (*.databases.neo4j.io), AuraDB Professional on GCP (*.databases.neo4j.io)), AuraDS (*.databases.neo4j.io) (AuraDS on AWS (*.databases.neo4j.io), AuraDS on Azure (*.databases.neo4j.io), AuraDS on GCP (*.databases.neo4j.io)), and AuraDS Enterprise (*.databases.neo4j.io) (AuraDS Enterprise on AWS (*.databases.neo4j.io), AuraDS Enterprise on Azure (*.databases.neo4j.io), AuraDS Enterprise on GCP (*.databases.neo4j.io)).