Potential unexpected query failures.

Incident Report for Neo4j Aura

Update

The fix for the trim() Cypher function is undergoing testing and validation before deployment.
Further updates will be provided before we begin deploying it to Aura instances.
Posted Aug 06, 2026 - 14:54 UTC

Update

We continue to validate the fix for the trim() Cypher function.
Further updates will be provided before we begin deploying it to Aura instances.
Posted Aug 06, 2026 - 11:17 UTC

Update

We continue to validate the fix for the trim() Cypher function.
Further updates will be provided before we begin deploying it to Aura instances.
Posted Aug 06, 2026 - 07:39 UTC

Update

We are actively validating the fix for the trim() Cypher function. Further updates will be provided before we begin deploying to Aura instances
Posted Aug 06, 2026 - 07:13 UTC

Update

We are testing the fix for the trim() Cypher function issue. We will update before we begin our deployment into the Aura environment.
Posted Aug 06, 2026 - 00:58 UTC

Identified

We have found the issue and are working on a fix. A small percentatge of queries using trim may still err.

VDC customers with databases set to highest are not impacted at all unless they pause and start their instances.
Posted Aug 05, 2026 - 19:27 UTC

Investigating

We have identified an issue currently that could result in unexpected query failures when using the trim() Cypher function. Investigations into the cause are in progress.
Posted Aug 05, 2026 - 17:31 UTC
This incident affects: AuraDB Virtual Dedicated Cloud (*.databases.neo4j.io) (AuraDB Virtual Dedicated Cloud on AWS (*.databases.neo4j.io), AuraDB Virtual Dedicated Cloud on Azure (*.databases.neo4j.io), AuraDB Virtual Dedicated Cloud on GCP (*.databases.neo4j.io)), AuraDB Professional (*.databases.neo4j.io) (AuraDB Professional on AWS (*.databases.neo4j.io), AuraDB Professional on Azure (*.databases.neo4j.io), AuraDB Professional on GCP (*.databases.neo4j.io)), AuraDS (*.databases.neo4j.io) (AuraDS on AWS (*.databases.neo4j.io), AuraDS on Azure (*.databases.neo4j.io), AuraDS on GCP (*.databases.neo4j.io)), AuraDS Enterprise (*.databases.neo4j.io) (AuraDS Enterprise on AWS (*.databases.neo4j.io), AuraDS Enterprise on Azure (*.databases.neo4j.io), AuraDS Enterprise on GCP (*.databases.neo4j.io)), AuraDB Business Critical (*.databases.neo4j.io) (AuraDB Business Critical (*.databases.neo4j.io) on AWS, AuraDB Business Critical (*.databases.neo4j.io) on Azure, AuraDB Business Critical (*.databases.neo4j.io) on GCP), and AuraDB Free (*.databases.neo4j.io).